Use on x64 Machines

Jan 5, 2010 at 2:40 PM

Has anyone had any luck with getting this to work with x64 machines. I get an error with this line in the web config on the 01XmlFileErrorLog type:

<errorLog type="OrbitOne.Elmah.O1XmlFileErrorLog, OrbitOne.Elmah, Version=1.0.0.0, Culture=neutral, PublicKeyToken=ab9cc0e617757f7b" LogPath="C:\Program Files\Orbit One\Orbit One Elmah Agent Service\Logs" />

When I hover over O1XmlFileErrorLog I get "Cannot resolve symbol .ctor" and when I run the app is breaks with "The requested page cannot be accessed because the related configuration data is invalid."

I found this post on elmah's board http://code.google.com/p/elmah/issues/detail?id=102 which seems to indicate it is a resharper issue, though I am pretty sure I had this the first time I tried elmah on this machine before I got the x64 version of elmah.

Is the version of elmah in the trunk tweaked, or can I just replace it with the latest elmah source and build it as x64?

Coordinator
Jan 6, 2010 at 12:22 PM

Hi,

First of, the elmah in the trunk is not tweaked so you should be able to use the latest elmah source.

However, we've been using it on 64-bit and 32 bit machines without any problems.

 

Does the logpath exist? Do you have the proper rights to write into the log folder?  try setting read/write open to everyone if unsure :-)

 

Hope this helped,

Grtz

 

Wim